First bug discovered!

Dear Early Adopters,

First of all we do thank to all the early adopters that bought our application, we really appreciate your willigness to try out a new application, especially in the crowded area of e-mail clients!

Unfortunately,  it seems that for iOS less than iOS 7 Aeria Mail crashes and cannot be used. We do apologise and we will issue an update as soon as possible. Until then, please do not buy it!

Now, why this happened? Well, it is very simple, since we are a couple of “indie” developers we cannot afford to have all test devices (iPods and iPhones) with all possible iOS versions (6.0.1, 6.0.2, 7.0.1, 7.0.2 and now 7.0.3). Accordingly, the application was not properly tested under various combinations of the two components. Of course, you might ask, why wasn’t the app properly tested with the simulator? Well, that’s exactly the question I will ask the developers!!!

Again, our apologies and rest assured that we are doing our best to correct it.